JoeBull

Newbie
Jul 27, 2022
4
0
1
43
Hello,

Why I always get invalid price EA error 129 when try to execute an instant trade?
Just testing, with Position Size Calculator ver. 2.42+ PSC scrpit works perfectly.
 

Attachments

  • invalide price.JPG
    invalide price.JPG
    91.9 KB · Views: 12
Last edited:

Enivid

Administrator
Staff member
Nov 30, 2008
16,982
1,020
144
Odessa
www.earnforex.com
Why I always get invalid price EA error 129 when try to execute an instant trade?
Just testing, with Position Size Calculator ver. 2.42+ PSC scrpit works perfectly.
Most likely, the price moves away while you are confirming it. Try removing the "Ask for confirmation" tick mark.
 
  • 👍
Reactions: EnrichWave

kamthind

Newbie
Jul 27, 2022
6
2
4
34
Hello

While testing I have noticed if I am adding a second trade to a pair (USTEC/NAS100/US100 in this example), which already has an active trade, when I use the Position Sizer to add a pending trade the Stop Loss is not applied. In this scenario the first trade had already met its BE parameter. I also added a trade with an instant execution and the stop loss was not applied to the trade.

I have attached the screenshots.

FYI - In the journal at 10:35:51:600 - The SL here was modified manually by me by typing in the SL value
 

Attachments

  • Screenshot 2022-07-29 at 10.46.34.png
    Screenshot 2022-07-29 at 10.46.34.png
    1 MB · Views: 8
  • Screenshot 2022-07-29 at 10.40.53.png
    Screenshot 2022-07-29 at 10.40.53.png
    1 MB · Views: 8
  • Screenshot 2022-07-29 at 10.37.16.png
    Screenshot 2022-07-29 at 10.37.16.png
    1 MB · Views: 8

Enivid

Administrator
Staff member
Nov 30, 2008
16,982
1,020
144
Odessa
www.earnforex.com
Hello

While testing I have noticed if I am adding a second trade to a pair (USTEC/NAS100/US100 in this example), which already has an active trade, when I use the Position Sizer to add a pending trade the Stop Loss is not applied. In this scenario the first trade had already met its BE parameter. I also added a trade with an instant execution and the stop loss was not applied to the trade.

I have attached the screenshots.

FYI - In the journal at 10:35:51:600 - The SL here was modified manually by me by typing in the SL value
What was the output in the Experts tab when you opened that trade?
 

iamkrrish009

Trader
Jul 29, 2022
5
1
8
30
It appears that your broker doesn't allow trade (either automated or generally) on this symbol. Perhaps, you should be using it on EURUSD.i, not EURUSD?

1659093982170.png

I just found the solution. I just unchecked these two options. Now it's working fine.
Thanks for quick response.
 

Enivid

Administrator
Staff member
Nov 30, 2008
16,982
1,020
144
Odessa
www.earnforex.com
Again sam

Again the problem is coming. Sometimes it is working and sometime it is not working
"Trade disabled" error is the platform/server issue. As I can see, you have enable autotrading properly. The only problem can be with the trading server. Perhaps, they are disabling trading during some news releases?
 

iamkrrish009

Trader
Jul 29, 2022
5
1
8
30
"Trade disabled" error is the platform/server issue. As I can see, you have enable autotrading properly. The only problem can be with the trading server. Perhaps, they are disabling trading during some news releases?
1659102623924.png
I think now my issue is solved. EA is not working only Forex currecy pairs. The EA is working fine with all other instruments
 

Enivid

Administrator
Staff member
Nov 30, 2008
16,982
1,020
144
Odessa
www.earnforex.com
View attachment 22204
I think now my issue is solved. EA is not working only Forex currecy pairs. The EA is working fine with all other instruments
It is likely the Forex section pairs are for reference only and not for trading. Or your broker disables trading them with EAs/scripts.
 

mi11tch

Trader
Aug 1, 2022
1
0
6
36
Hi, i am having the smae issue with the brekeven fucntion. when i adjust the tp the trade auto adjusts the stop to brekeven. How can i get around this issue
Post automatically merged:

Hi, i am having the same issue with the breakeven function. when i adjust the tp the trade auto adjusts the stop to breakeven. How can i get around this issue

Is there a way to change the breakeven fucnction off, i used the old position size calculator and loved it
 

Enivid

Administrator
Staff member
Nov 30, 2008
16,982
1,020
144
Odessa
www.earnforex.com
Hi, i am having the smae issue with the brekeven fucntion. when i adjust the tp the trade auto adjusts the stop to brekeven. How can i get around this issue

Hi, i am having the same issue with the breakeven function. when i adjust the tp the trade auto adjusts the stop to breakeven. How can i get around this issue

Is there a way to change the breakeven fucnction off, i used the old position size calculator and loved it
So, what exactly are you doing? Are you manually changing the open position's take-profit? Or are you changing the TP level of the Position Sizer? Does that cause the actual stop-loss of an open trade to adjust? Do you have Breakeven field on the Trading tab set to zero?
 
Last edited: