Enivid

Administrator
Staff member
Nov 30, 2008
16,040
817
144
Odessa
www.earnforex.com
Hello, I have received errors on both the position size calculator and the risk calculator inside the metaeditor. Each have about 100 errors.. how can this be fixed? Thank you
Please make sure you that you are following the installation instructions exactly - i.e., you are copying all the files to correct locations. Please also make sure that you are compiling an .mq4 file and not .mqh ones.
 

Csaba911

Newbie
Sep 22, 2021
4
0
1
53
I'm not sure how you even managed to get it work in 1345. That build is a beta with known bugs and the Risk Calculator shows completely blank for me there.
Thanks for your reply. All major brokerage firms are asking us to upgrade to the 1345, so I though that was kind of mandatory. Now I'm realising that this could have been a bit risky as you stated it was in beta and full of bugs. When I run an existing profile I was able to partially see Risk Calculator. However if I start a Chart from scratch and add the Indicator it sure is blank. Now I'm asking myself how to roll back to the previous version since those are no longer downloadable. Hopefully there will be a release anytime soon as as 1345 is a bit messy. Or do you guys have any other suggestions?
 

Csaba911

Newbie
Sep 22, 2021
4
0
1
53
I'm not sure how you even managed to get it work in 1345. That build is a beta with known bugs and the Risk Calculator shows completely blank for me there.
Thanks a lot for your reply. Many brokerage firms have sent me a mail to upgrade specifically stating to upgrade to this particular Version. So I did which resulted in this error. Now that I know that it is a beta version with lots of bugs it makes sense. I was able to see Risk Calculator when I used my existing profile. When I start a new chart and try to add the indicator it sure gives me a blank screen. So now my question is should I roll back or wait for another update since older versions no longer are listed with the CFD Brokers. What do you guys suggest?
 

Enivid

Administrator
Staff member
Nov 30, 2008
16,040
817
144
Odessa
www.earnforex.com
Thanks a lot for your reply. Many brokerage firms have sent me a mail to upgrade specifically stating to upgrade to this particular Version. So I did which resulted in this error. Now that I know that it is a beta version with lots of bugs it makes sense. I was able to see Risk Calculator when I used my existing profile. When I start a new chart and try to add the indicator it sure gives me a blank screen. So now my question is should I roll back or wait for another update since older versions no longer are listed with the CFD Brokers. What do you guys suggest?
Actually, only one (IG) of about 15 of my MT4 instances got updated to 1345. I see reports on the MQL5 official forum saying that some terminals are getting updated to the next beta - 1347 - where this issue is presumably fixed. You could try waiting for your terminals to update to 1347.
 

Csaba911

Newbie
Sep 22, 2021
4
0
1
53
Actually, only one (IG) of about 15 of my MT4 instances got updated to 1345. I see reports on the MQL5 official forum saying that some terminals are getting updated to the next beta - 1347 - where this issue is presumably fixed. You could try waiting for your terminals to update to 1347.
Thanks for your reply. In the meantime I rolled back to the build 1340 and everything is working as expected. The CFD Brokers that have build 1345 in their installation and specifically asked us to install to this latest version via Email Message are Axiory, FxPro, SwissQuote and XM-Global.
 

Enivid

Administrator
Staff member
Nov 30, 2008
16,040
817
144
Odessa
www.earnforex.com
Thanks for your reply. In the meantime I rolled back to the build 1340 and everything is working as expected. The CFD Brokers that have build 1345 in their installation and specifically asked us to install to this latest version via Email Message are Axiory, FxPro, SwissQuote and XM-Global.
Good to hear that. Let's hope those brokers update to 1347 or later build sooner or later.