EA not taking Trade

Jixo man

Trader
Jul 26, 2020
46
1
14
Good morning traders. I am kinda new to mql4 and coding in general. Here is an EA on moving average I tried to modify . But it is not working. I tried it on strategy tester it did not work likewise. Please help. Thanks for your help. I know someone will help fix it.
 

Attachments

  • JIXO567.mq4
    5.7 KB · Views: 1

Jixo man

Trader
Jul 26, 2020
46
1
14
What errors do you get in the Journal tab when backtesting?

I first got unint 5, so I thought because it was on two instructions it wouldn't work. So I removed one chart leaving just one instructment on my mt4. But it would not trade after a long day. So I thought maybe there is a problem with it.
 

Jixo man

Trader
Jul 26, 2020
46
1
14
What errors do you get in the Journal tab when backtesting?
Also for the backtesting it just displays waiting. I did not check it. I guess I would have to check it. Even if it was unable to take trade on a demo account the back testing should have work.
 

Enivid

Administrator
Staff member
Nov 30, 2008
14,204
636
144
Odessa
www.earnforex.com
Also for the backtesting it just displays waiting. I did not check it. I guess I would have to check it. Even if it was unable to take trade on a demo account the back testing should have work.
What is displaying "Waiting"? Does backtesting finish? You should be able to view the backtesting Journal even if it isn't finishing.
 

Jixo man

Trader
Jul 26, 2020
46
1
14
What is displaying "Waiting"? Does backtesting finish? You should be able to view the backtesting Journal even if it isn't finishing.
It does not start. I don't have electricity now . I will try it and probably send you a screenshot.. You that EA I just modify a existing moving average EA
 

Jixo man

Trader
Jul 26, 2020
46
1
14
What is displaying "Waiting"? Does backtesting finish? You should be able to view the backtesting Journal even if it isn't finishing.
This is the error message I got when I used strategy tester. It trade the EA for a whole on different pair not one trade was taken.
 

Attachments

  • asd.PNG
    asd.PNG
    24 KB · Views: 4
  • ase.PNG
    ase.PNG
    12.4 KB · Views: 4
  • JIXO567.mq4
    5.7 KB · Views: 2

Jixo man

Trader
Jul 26, 2020
46
1
14
It is what it says, the trading server you are connected to has no data for the pair/timeframe for the period you selected.
Thanks sir.
I tried it on other pair as well.
I also open a demo account to test the EA. And still no trade taken. I am tired and don't know what to do. I watch a tutorial on YouTube on how to back test an EA . I did same. What do you recommend.
 

Enivid

Administrator
Staff member
Nov 30, 2008
14,204
636
144
Odessa
www.earnforex.com
Try a different broker. I have no idea about anything that might be happening when you try to forward-test it on demo, but the backtesting log clearly says that the broker doesn't have data for backtesting - you won't get any trades if there is no data to backtest on.
 
  • Like
Reactions: Jixo man

Jixo man

Trader
Jul 26, 2020
46
1
14
I
Try a different broker. I have no idea about anything that might be happening when you try to forward-test it on demo, but the backtesting log clearly says that the broker doesn't have data for backtesting - you won't get any trades if there is no data to backtest on.
I will try that
Thanks so much
 

hayseed

Master Trader
Jul 27, 2010
490
138
109
usa
hayseedfx.com
Thanks sir.
I tried it on other pair as well.
I also open a demo account to test the EA. And still no trade taken. I am tired and don't know what to do. I watch a tutorial on YouTube on how to back test an EA . I did same. What do you recommend.
//----

hey jixo man..... try force downloading all data on each pair and time frame..... a normal new demo will probably not have that much 5 minute history..... so you can not test a 2 month period last winter.....

try running a back test for only the past month or week..... or specify todays date as the end date....

your ea does work and backtests fine for me........

unless you have had your account open for many years you might only have a few thousand 5 minute bars..... h
 

Jixo man

Trader
Jul 26, 2020
46
1
14
//----

hey jixo man..... try force downloading all data on each pair and time frame..... a normal new demo will probably not have that much 5 minute history..... so you can not test a 2 month period last winter.....

try running a back test for only the past month or week..... or specify todays date as the end date....

your ea does work and backtests fine for me........

unless you have had your account open for many years you might only have a few thousand 5 minute bars..... h
Thanks