Phylix

Newbie
Jan 5, 2022
5
1
1
25
I just re-compiled the .mq4 file and it has 101 errors and 8 warnings. I don't know how to correct the code errors, do have a working code you can share with me?
 

Attachments

Phylix

Newbie
Jan 5, 2022
5
1
1
25
I just re-compiled the .mq4 file and it has 101 errors and 8 warnings. I don't know how to correct the code errors, do have a working code you can share with me?
Never mind, stupid me didn't follow instructions. I only copied the .mq4 files when I'm supposed to copy the whole Account Protector folder into the Experts folder.

Thanks for helping :)
 
  • Like
Reactions: Enivid

Enivid

Administrator
Staff member
Nov 30, 2008
16,131
835
144
Odessa
www.earnforex.com
My apologies for beeing stupid.
How do I install the advisor in MT5?
I downloaded the files from here or GITHUB: https://www.earnforex.com/metatrader-expert-advisors/Account-Protector/#Usage

and then I just pasted in the MT5 folder:
C:\Users\vps-user\AppData\Roaming\MetaQuotes\Terminal\xxxxxx\MQL5\Experts\Advisors
but MT5 does not recognize it as MQL5 program.

What am I doing wrong?
Try compiling the Account Protector.mq5 file with your MetaEditor. Does it produce any errors? If not, can you attach it now in MT5?
 

bilyng

Trader
Jan 13, 2022
1
1
8
41
Hi, I am testing this EA and it appears the emergency button is not working as it should.

When pressed, the only thing it does is to disable autotrading and close pending orders
It does not close any trades.

The expert tab says all positions closed, pending orders deleted, autotrading disabled.
but the trades stay open, but pending orders get deleted and autotrading is disabled.

Is there any setting i am missing?
 
  • Like
Reactions: Enivid

Enivid

Administrator
Staff member
Nov 30, 2008
16,131
835
144
Odessa
www.earnforex.com
Hi, I am testing this EA and it appears the emergency button is not working as it should.

When pressed, the only thing it does is to disable autotrading and close pending orders
It does not close any trades.

The expert tab says all positions closed, pending orders deleted, autotrading disabled.
but the trades stay open, but pending orders get deleted and autotrading is disabled.

Is there any setting i am missing?
Looks like a bug. I'll fix it in the next release of the Account Protector.